trinityamps.com

Trinity Amps Guitar Amp Forum
It is currently Tue Oct 04, 2022 3:18 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sat Aug 06, 2022 3:02 am 
Offline

Joined: Mon Jul 11, 2022 11:38 am
Posts: 3
I recently bought a used tramp in excellent condition. After much research, I decided to pair it with a Tone Tubby Chicago blue speaker (AlNico 30 watt). It’s the darkest amp I’ve ever played through. I was playing with a strat with single coils and I had to max out the treble just to get a usable tone. Is this normal for this amp? I researched the Chicago Blue speaker before purchasing and nothing ped me to believe that it would darken the amp and reduce presence. I’ll admit that so far I’ve only used the amp with a vintage RCA 6v6 and the stock 12ax7. Im not sure changing the preamp tube would add treble/presence. I also have a 50 watt Jupiter 12LA AlNico speaker I can try. I just wanted to check here before doing that because mounting a speaker in this cabinet was a huge hassle that involved me taking off both rear panels and the chassis. Any advice is appreciated. It’s also my first post on the forum! Wohoo!


Top
 Profile  
 
PostPosted: Mon Aug 08, 2022 5:18 pm 
Offline

Joined: Mon Jul 11, 2022 11:38 am
Posts: 3
is anyone out there?


Top
 Profile  
 
PostPosted: Tue Aug 23, 2022 11:59 pm 
Offline

Joined: Tue Aug 23, 2022 11:52 pm
Posts: 1
There is me, but I am not a pro one in this field. Therefore, I cannot give you a good suggesttion.
Stickman Boost


Top
 Profile  
 
PostPosted: Wed Sep 21, 2022 7:14 pm 
Offline

Joined: Mon Jul 11, 2022 11:38 am
Posts: 3
update: I have now tested the amp with EL34, 6V6, and 5881 tubes as well as different preamp tubes. I also tried out a telecaster and p-90 equipped guitars. Same results. It still seems dark compared to my other amps and maxing out the treble is where it sounds the most usable. I compared it side by side with a Magnatone Varsity (12 watt) and also tried swapping a couple different speakers. Still not sure if it's the circuit or maybe there is a value that is off in the build that seemed to darken up the amp. I still love the overdrive and tones, just trying to get used to the sound.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group